Shadowrun

Catalyst Game Labs => Forum Business => Topic started by: AJCarrington on (20:35:04/03-08-15)

Title: Load Times
Post by: AJCarrington on (20:35:04/03-08-15)
Anyone noticing excessive load times for pages recently?
Title: Re: Load Times
Post by: 8-bit on (20:57:12/03-08-15)
Yes. It takes an average of 30 seconds to load the page; and one of my replies took a whole 3 minutes to process (roughly).

I thought it was just my internet, as I'm in a different location than normal.
Title: Re: Load Times
Post by: Namikaze on (23:36:39/03-08-15)
Ironically, it took 15 seconds longer than normal to load this page to write this reply.  :P

Yes, I've noticed it the last...  2, maybe 3 days.  I've seen the forums go through this before, and it eventually resolves itself.  So my thinking is that there's a server that needs rebooting.
Title: Re: Load Times
Post by: Tarislar on (00:59:27/03-09-15)
I've noticed it for a couple days.  Glad its not just me.  I was worried it was my net or a virus.
Title: Re: Load Times
Post by: AJCarrington on (06:48:01/03-09-15)
Thanks guys, glad it's nit just mc losing g my mind ::)
Title: Re: Load Times
Post by: AJCarrington on (12:08:05/03-11-15)
Seems MUCH better today!!! ;D
Title: Re: Load Times
Post by: Knightmare on (08:58:06/03-12-15)
We've been hard at work on making some grid improvements—one particularly nasty sprite took my best ice to geek her—but we're almost finished.

Now where did I leave that bat prog Slamm-O! gave me?...
Title: Re: Load Times
Post by: AJCarrington on (08:59:44/03-12-15)
Whatever you're doing...keep it up! Don't think I've ever seen the forums this fast or responsive.

Now all we need is that Tapatalk plugin  8)
Title: Re: Load Times
Post by: Knightmare on (09:29:37/03-12-15)
I'm considering it, but not for this round of updates.

With this update we've already added quite a bit, and I will need a few months of continual operation and some additional testing before adding tapatalk.

Title: Re: Load Times
Post by: Kincaid on (10:03:13/03-12-15)
Yay!  Thanks for your efforts.
Title: Re: Load Times
Post by: AJCarrington on (10:39:14/03-12-15)
I'm considering it, but not for this round of updates.

With this update we've already added quite a bit, and I will need a few months of continual operation and some additional testing before adding tapatalk.

Understood...glad to hear that it *might* be on the radar ;)
Title: Re: Load Times
Post by: Tarislar on (18:54:42/03-16-15)
It was fast for a while & now today I'm getting some intermittent slow times again.  :(

Title: Re: Load Times
Post by: Knightmare on (20:51:50/03-16-15)
It's not the forum. I'm seeing the same thing on the BT forums. I'll offer a definitive answer as soon as I'm finished checking some things.
Title: Re: Load Times
Post by: AJCarrington on (09:06:11/03-20-15)
Load times see pretty erratic this morning...??? :-\
Title: Re: Load Times
Post by: jim1701 on (15:56:13/03-20-15)
They've been pretty bad all morning for me.   :P
Title: Re: Load Times
Post by: Zweiblumen on (17:32:31/03-20-15)
Yeah, I've been having problems as well.
Title: Re: Load Times
Post by: PiXeL01 on (07:06:38/03-23-15)
Same here for the past few days.
Title: Re: Load Times
Post by: AJCarrington on (07:11:20/03-23-15)
Seems to be much better this morning though...will wait to see how things progress over the day.
Title: Re: Load Times
Post by: Snake Eyes on (13:55:07/03-23-15)
Seems that the load time is bad again
Title: Re: Load Times
Post by: AJCarrington on (17:19:21/03-23-15)
Yeah...as soon as I sent that last note, the lag started up again...really intermittent.
Title: Re: Load Times
Post by: Knightmare on (20:34:02/03-23-15)
Still working on this...
Title: Re: Load Times
Post by: Tarislar on (21:18:15/03-25-15)
Yay!  :)
Because its crazy slow today   :(
Title: Re: Load Times
Post by: All4BigGuns on (12:36:17/03-27-15)
Been seeing this with this site for the past week to week and a half, and it's only affecting me with this site.
Title: Re: Load Times
Post by: Darzil on (06:17:50/04-06-15)
Fingers crossed you're getting closer to pinpointing the issue.
Title: Re: Load Times
Post by: AJCarrington on (12:11:22/04-06-15)
I'm still finding it pretty hit-or-miss...doesn't seem to be a pattern or logic to when the lag hits. :(
Title: Re: Load Times
Post by: PiXeL01 on (12:16:36/04-06-15)
Here in Japan it's been continuously bad the past month or so.

Hoping for noiseless days!
Title: Re: Load Times
Post by: Darzil on (18:10:55/04-06-15)
Intermittently slow performance on something database based always makes me wonder if there are indexes needed. Some databases generate them automatically, others need help.
Title: Re: Load Times
Post by: Ursus Maior on (18:58:11/04-06-15)
Same here in Germany. Haven't had a decent loading rate for some months now.
Title: Re: Load Times
Post by: Tarislar on (19:53:01/04-06-15)
Everyone once in a while I'll get a few clicks that go fast.  But most of them have been slow for over a month now.
Title: Re: Load Times
Post by: Knightmare on (19:58:23/04-14-15)
I've turned off PrettyURLs. I found the forum's connection to the DB was causing extreme slowness with the new URLs. It was intermittent, but until I find the cause I've removed them. Your individual caches may reset on first load, but should improve.

I'll keep everyone posted.
Title: Re: Load Times
Post by: Ursus Maior on (03:52:03/04-15-15)
It has improved considerably. Thank you very much.
Title: Re: Load Times
Post by: Darzil on (16:09:06/04-18-15)
Yeah, that's a LOT better.

Edit - Though weirdly posting that took a while.

I suspect there are still some performance edge cases, but for me it's now 1 page in 10 takes 15 seconds to load, rest are less than a second, rather than 5 pages in 10 takes 2-3 minutes to load, and 5 in 10 only 15 seconds.
Title: Re: Load Times
Post by: Ursus Maior on (17:32:25/04-18-15)
And back to slow.
Title: Re: Load Times
Post by: Agonar on (17:35:08/04-20-15)
And back to slow.

Seconded.  The past few days, the loading/refresh/posting times has gotten horribly slow.  I was beginning to think it was on my end, until I tried it also on my mobile devices.  Glad.. well, no, I am not glad that it is slow for everyone, but it's nice to know it's not just me.
Title: Re: Load Times
Post by: toad on (21:48:23/04-20-15)
Everyone once in a while I'll get a few clicks that go fast.  But most of them have been slow for over a month now.

^ Same for me
Title: Re: Load Times
Post by: Darzil on (07:44:03/04-26-15)
Not sure if it helps, but it might.

Just tried opening up pages in another tab, so I could be reading one post whilst another was opening. I noticed that the 5 tabs all sat on loading, then all completed at pretty much the same time. Could be a blocking thread or something on the server rather than loading particular posts?
Title: Re: Load Times
Post by: toad on (22:27:43/05-07-15)
Any updates on this?

I love these forums, but it sure can be painful to use at times.
Had a number of 10-15 second load times, and even a 25 second load time tonight.  :-[
Title: Re: Load Times
Post by: Knightmare on (10:41:05/05-31-15)
There's some slowness across the forums. We're working on it.
Title: Re: Load Times
Post by: PeterSmith on (17:25:05/06-05-15)
Seems quicker. Database get some attention?
Title: Re: Load Times
Post by: Raven2049 on (08:18:56/06-14-15)
dont know what you guys did recently but load times have increased dramatically. keep up the good work!

strangely enough this forum is working properly again!  8)
Title: Re: Load Times
Post by: AJCarrington on (09:01:07/06-14-15)
Agreed...things appear to be running a LOT quicker. ;D
Title: Re: Load Times
Post by: Zweiblumen on (18:47:06/06-16-15)
++ to the loading speeds.  MUCH improved.  Thanks, and keep up the great work!
Title: Re: Load Times
Post by: prionic6 on (08:37:36/06-17-15)
Ludicrous speed!
Title: Re: Load Times
Post by: Ursus Maior on (08:22:34/06-22-15)
Great! Almost instant access. :)
Title: Re: Load Times
Post by: toad on (20:37:21/06-23-15)
I had actually stopped visiting for a while, because of the slowness.

It's so much better now, thanks!  :)
Title: Re: Load Times
Post by: ScytheKnight on (04:18:53/07-28-15)
Someone needs to feed the server hamsters again...
Title: Re: Load Times
Post by: AJCarrington on (07:31:26/07-28-15)
Really? I haven't noticed any of the speed/load issues we used to have...
Title: Re: Load Times
Post by: Zweiblumen on (13:49:37/07-28-15)
Speeds seem pretty good to me as well.
Title: Re: Load Times
Post by: farothel on (16:35:54/07-28-15)
This morning it was slow for a while, but now it's back up again.
Title: Re: Load Times
Post by: ScytheKnight on (18:45:39/07-28-15)
Hmmmm.... just every now and then the site has a lot of trouble loading pages. Was pretty bad for that yesterday.
Title: Re: Load Times
Post by: PeterSmith on (07:44:32/07-29-15)
I saw page loading issues earlier this week as well, I don't have specific times.
Title: Re: Load Times
Post by: adamu on (16:25:49/04-06-16)
Hate to revive this thread, but this is still a huge problem for me.

I have it at home, on my mobile, and even at work (where the computers are, like, badass).
So I am thinking it is not just me?
Or is it?

I am computer stupid, but is there a fix in sight - waiting two or three minutes a lot of times for a page to load, which really slows down my GM chores.

Some days better others - today hasn't been quite as bad.

Thanks to anyone that reads this!
Title: Re: Load Times
Post by: Beta on (17:12:17/04-06-16)
I'm not at two or three minutes, but my loads here are frequently noticeably slower than pretty much any other site I visit.
Title: Re: Load Times
Post by: AJCarrington on (09:28:04/04-07-16)
I've been experiencing this sporadically over the last week or two as well. Strangely enough, today, things seem to be working quite well.
Title: Re: Load Times
Post by: Zweiblumen on (16:23:09/04-15-16)
This has definitely been a problem for me for the past 10 days or so.  I know a few other posters have mentioned it in a few of the threads I'm in.

Pure speculation puts this as a caching/DB performance problem.  HTTP is responding just fine.
¯\_(ツ)_/¯
Title: Re: Load Times
Post by: All4BigGuns on (21:01:53/04-15-16)
Don't know what causes this sluggishness, but I do know that every couple of months it just gets ridiculously slow in comparison to just about every other website on the net. They'll get it fixed and then a couple months later it's right back to being slow again.
Title: Re: Load Times
Post by: adamu on (17:42:18/04-18-16)
Yes. Exactly.

There are times I have to just economize time by clicking on something, then going and doing something else useful, then coming back, writing, hitting post, then off I go again to do something else IRL or on another site for five minutes (and sometimes the new page still hasn't come up!).

It's literally having a chilling effect on the amount of time I'm spending on this site.
Title: Re: Load Times
Post by: PeterSmith on (10:24:36/04-19-16)
Don't know what causes this sluggishness, but I do know that every couple of months it just gets ridiculously slow in comparison to just about every other website on the net. They'll get it fixed and then a couple months later it's right back to being slow again.

That sounds like a server/database maintenance issue more than anything else.
Title: Re: Load Times
Post by: Quatar on (17:45:30/04-20-16)
Right now the forum performance is fairly horrible again. I'm clicking a link and have to wait about 30 seconds before anything even starts to happen, sometimes it takes even longer than.

And I'm just reading not doing anything crazy.

I agree with PeterSmith, this feels like a database issue somehow. Is the forum software maybe not relinquishing server connections to the SQL server properly when it's done with a session or something like that? (usually shouldn't happen because the SQL Server has a timeout setting too, but maybe that's not working right)

Databases are usually really good at handling huge amounts of data, so it's likely not "there's just too much in there", also then it wouldn't get better again.

Whatever it is, there's definitely a bottleneck somewhere, and something hogging all the database access would certainly qualify.
The fact that it seems to pop up in (more or less) regular intervals suggests it's some kind of "memory leak" issue, where some resources aren't properly freed up again, even though they're not in use anymore.
Title: Re: Load Times
Post by: Irn0rchid on (21:03:00/05-13-16)
This is still a pretty annoying issue. They said on twitter that they're planning a server upgrade, but no ETA, so...
Title: Re: Load Times
Post by: AJCarrington on (18:07:13/05-14-16)
Yeah, things have been pretty spotty recently. I'll poke around to see if I can get any more info.
Title: Re: Load Times
Post by: adamu on (04:42:51/05-18-16)
I just now typed a post.

Hit reply.

Watched nothing happen for a minute or so.

Went over to Dumpshock and made a post.

Came back - still nothing.

Went and had breakfast and when I came back the post had finally gone up.

Getting worse.

Appreciate anything you can do!
Title: Re: Load Times
Post by: farothel on (06:50:22/05-18-16)
I'm even getting network time-outs from time to time.  Since I don't have it with other websites, I assume it's on the server end and not my end.  Next time I have one, I'll copy it and put it up here.  It's not saying anything to me, but it might to someone who actually knows something about it.
Title: Re: Load Times
Post by: farothel on (06:53:56/05-23-16)
I've had the timeouts again and I got two different errors.  I'll put them here so the tech people can see if it helps them with knowing what's going in.

first one:
Network Error (tcp_error)

A communication error occurred: ""
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.

For assistance, contact your network support team.


second one:
Connection Problems

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.
Title: Re: Load Times
Post by: PeterSmith on (10:09:15/05-24-16)
Fortunately a new server is in sight. No specific date, but it's happening.
Title: Re: Load Times
Post by: Pixelated on (01:26:53/07-10-16)
So weird but I know a Peter Smith in real life who introduced me to SR 2nd edition a looong time ago :P Glad to see delay is not just me! Here's for upgrades! \o/
Title: Re: Load Times
Post by: Reaver on (09:59:09/07-10-16)
Nope, its not just you :(

Sadly the server takes up to 2 minutes to respond for me somedays as well.... which makes posting from a phone a challenge (keeps shutting down, waiting for the server to respond).

Used to be some in the office would go feed the hamster, and server would settle down again.... I'm guessing said hamster has been over-fed and no longer fits in his wheel, thus he can't cycle the server fast enough anymore for the activity.....
Title: Re: Load Times
Post by: Irn0rchid on (14:03:15/08-02-16)
Load times are pretty brutal (and sporadic) yesterday/today...
Title: Re: Load Times
Post by: Imladir on (03:05:09/08-05-16)
Load times are often bad, sometimes depressingly so.
The forum was unresponsive (timeouts) for thirty minutes just now. That's quite lame.
Oh and after that, just to add insult to injury, we went straight to connection problems to the database.

Yeah, "a new server is in sight". It could be reassuring if it wasn't first announced in May. Or if the forum's engine wasn't outdated since September, 18th. Since we're in august, with the holidays here, I won't insist too much on  the fact that all mails are blocked (http://forums.shadowruntabletop.com/index.php?topic=24584.0) since a few days ago (and not for something trivial, but because of a trojan on the server) with no official answer, but it's not looking good either.

So, any concrete news, or will we see all traffic end up on Dumpshock?
Probably a dumb question given the age of the thread, I know, but...
Title: Re: Load Times
Post by: AJCarrington on (07:10:24/08-05-16)
No official word at the moment.

The email issue has been reported...I believe it is impacting the BattleCorp store as well as the forums. I expect that to get addressed shortly, but given GenCon, not sure we'll see anything until next week.
Title: Re: Load Times
Post by: Imladir on (09:23:05/08-05-16)
I'd really like to believe that everything will be right after GenCon...
Title: Re: Load Times
Post by: Imladir on (23:27:43/08-30-16)
For at least six hours now the forum was completely unresponsive (as in always timing out, no matter which page was loading).
Title: Re: Load Times
Post by: Irn0rchid on (23:50:37/08-30-16)
Yup! It's improved now though! It only takes 30-45 seconds to load a page!
Title: Re: Load Times
Post by: EiraHaexa on (23:52:36/08-30-16)
For at least six hours now the forum was completely unresponsive (as in always timing out, no matter which page was loading).

Seriously. A six hour outage leads me to believe someone may have deliberately fragged with the server. Seems to be working ok at the moment, however.
Title: Re: Load Times
Post by: Imladir on (00:21:48/08-31-16)
Nah, it's much simpler, there are too many messages right now for the forum to handle easily (which is probably due to a mix of a low-tier server, no maintenance in the last year, etc). Maybe some conflicting mods, etc.
Trimming the useless stuff in the database (expired cache sessions and so on) could probably improve things a bit.
Title: Re: Load Times
Post by: EiraHaexa on (00:38:34/08-31-16)
Nah, it's much simpler, there are too many messages right now for the forum to handle easily (which is probably due to a mix of a low-tier server, no maintenance in the last year, etc). Maybe some conflicting mods, etc.
Trimming the useless stuff in the database (expired cache sessions and so on) could probably improve things a bit.

Makes sense. I have noticed quite a few new members on the boards. There may be simply too many now for the server to handle, especially if there's a lot of old inactive accounts (like, haven't been logged in for over a year) cluttering things up.
Title: Re: Load Times
Post by: Irn0rchid on (17:26:36/08-31-16)
Server:Maintenance::Books:Errata? :P
Title: Re: Load Times
Post by: Irn0rchid on (09:24:44/10-03-16)
So the forums are extra bonus slow this morning. Any word on some sort of improvement?
Title: Re: Load Times
Post by: farothel on (05:21:44/10-04-16)
I'm getting more and more time-out errors lately.  It's not easy playing a PbP when you're never sure if your post is going to make it through (I now save each one in a temp file just to make sure I don't have to retype it).
Title: Re: Load Times
Post by: Reaver on (06:42:05/10-04-16)
I'm getting more and more time-out errors lately.  It's not easy playing a PbP when you're never sure if your post is going to make it through (I now save each one in a temp file just to make sure I don't have to retype it).

Yea... I lost a huge post I was working when the site had a hiccup.... might just start writing stuff out in wordpad then Copy/Paste when I am done... but that only really helps me when I have a computer... I mostly post from my phone :(
Title: Re: Load Times
Post by: Beta on (11:24:22/10-04-16)
This is why some games/threads moved over to the forums at Dumpshock.  Of course, Dumpshock has now been down since the weekend, so that may or may not have been a good decisions …
Title: Re: Load Times
Post by: Reaver on (13:25:48/10-04-16)
<facepalm>

Me thinks it was a shadow Op....

Someone's employer somewhere has said "Little Johnny is spending too much time surfing this site a work. Deal with it."
Title: Re: Load Times
Post by: EiraHaexa on (13:34:35/10-04-16)
My money is on Deus.
Title: Re: Load Times
Post by: Irn0rchid on (15:02:59/10-04-16)
With it starting on the 1st, my money is on a bill not being paid. :P
Title: Re: Load Times
Post by: Dwagonzhan on (16:22:19/10-18-16)
Since I joined, I've been relenting in most of my posting simply because the combination of horrific loading issues and my garbage internet have caused me to lose many, many posts (and patience).
It's to the point where I save any post longer than a few sentences (to notepad or clipboard).
Title: Re: Load Times
Post by: AJCarrington on (10:25:20/10-20-16)
It's to the point where I save any post longer than a few sentences (to notepad or clipboard).

In fairness (not taking away from the issues we have here), this is good practice regardless of the you're posting on.
Title: Re: Load Times
Post by: Stoneglobe on (06:19:55/11-13-16)
This is something I have always suffered from and if anything is getting worse and not better. Just to be able to add this post has taken me almost 10 minutes of waiting for the page to load and having to relaunch several times. This isn't a one off occurrence either but more a regular or even daily problem.